Taking the Hiss out of QO-100

I’ve been on the QO-100 satellite for about 7 months now and I have to admit I love it!

Having a “Repeater In The Sky” that covers a third of the world really is a wonderful facility to have access to however, there is one thing that I find tiring and that is the high level of background noise that is always present.

Even though the signals are mostly 59-59+15dB the background “hiss” is very pronounced and gets very tiring after a while, especially if like me you have tinnitus.

Currently I’m using a NooElec Smart SDR for the receiver and GQRX SDR software on my Kubuntu Linux PC. This works great but, there is one short fall, there is no DSP Noise Reduction (NR) in the software or hardware.

To fix this I recently invested in a BHI Dual In-Line Noise Eliminating Module. The unit itself is nicely put together and has a good combination of inputs and outputs making it easy to connect up to my MacBook Pro to record QSOs and connect my headphones at the same time.

M0AWS BHI Dual In-Line Noise Eliminating Module
M0AWS BHI Dual In-Line Noise Eliminating Module

At £189.95 plus postage from BHI direct it’s not cheap but, it is nicely put together and comes complete with a power lead and a couple of cheap audio cables. The quality of the knobs and mechanisms is good apart from the little grey DSP Filter Level knob that feels cheap and is very wobbly on the switch below. I’m not sure how long this is going to last with prolonged use and will most likely need replacing with something a little sturdier at some point in the future.

Overall noise reduction is good but, the audio amplifiers on the Audio Input Level and Line Out Level distort very early on in their range and you cannot get them much above level 5 before distortion starts to appear on the received signal. This is disappointing as my headphones are of reasonable quality and are let down by the distortion creeping in from the audio amplifier in the BHI unit.

I’ve tried altering the levels on the input from the IC-705 and no matter what I cannot get a good audio signal in my headphones without some distortion on the higher frequency ranges.

Overall the device does do what I want, it reduces the background “hash” considerably reducing the fatigue whilst chatting on the satellite. Below is a recording from a conversation on the satellite showing the noise reduction performance of the BHI module.

M0AWS Example BHI DSP NR Recording

The recording starts with the BHI DSP NR off, at 00:07 the DSP NR is switched on, you can clearly hear the difference. At 00:23 the DSP NR is turned off again and at 00:36 the DSP NR is turned on again. The BHI DSP NR Module is set with the DSP Filter Level set at 3 out of 8 which appears to be the best level to use. Switching to level 4 starts to introduce digital artefacts to the audio which only gets worse the higher the DSP Filter Level goes.

With a setting above level 3 there really isn’t much improvement in noise reduction and the audio becomes progressively more affected by the digital artefacts than it does from the background noise.

M0AWS BHI Dual In-Line Noise Eliminating Module with Icom IC-705 QO-100 Ground Station
M0AWS BHI Dual In-Line Noise Eliminating Module with Icom IC-705 QO-100 Ground Station

The only other problem I have with the BHI Dual In-Line Noise Eliminating Module is that is comes in a plastic case. The case itself is solid and of good quality however, it offers no RF shielding whatsoever and the unit is extremely susceptible to RF getting into the audio chain and then being heard during transmit in the headphones and via the line out connections. For the money I would had expected the unit to come in a metal case that provides proper RF shielding. This is a real shame as it lets the unit down considerably.

As setup in the photo above I am using 300mW O/P on 144Mhz from the IC-705 into a perfect 1:1 SWR presented by the DX Patrol 2.4Ghz Upconverter via some very high quality LMR-400 Coaxial cable from Barenco but, I get terrible RF interference via the BHI unit during the transmit cycle. Considering I am only using 300mW I dread to think what it may be like if I was using a 100w HF radio. This is something I need to investigate further as it really is very annoying.

Moving the unit to a different location in the radio room does help a bit but, doesn’t solve the problem completely. At 300mW RF O/P I really didn’t expect there to be a problem with RF getting into the BHI unit.

Having a proper line-out facility on the BHI unit really is nice as it makes it very easy to connect to my MacBook Pro to obtain good quality recordings of signals on the QO-100 satellite as can be listened to above.

Overall I am happy with the BHI Dual In-Line Noise Eliminating Module but, do wish that more care had been taken over using a metal case instead of a plastic case to protect the unit from RF ingress and better audio amplifiers within the unit that don’t distort/clip so early on in their O/P levels.

Is this the perfect noise reduction unit?


No but, overall it is better than nothing and does help to reduce the background noise to a more acceptable level reducing the overall fatigue during prolonged conversations on the QO-100 satellite.

UPDATE: I tried the BHI unit with my FTDX10 on the HF bands and the RF interference is horrendous, even when using QRP power levels! This device clearly hasn’t been designed to work in an RF environment and the total lack of shielding or isolation lets it down terribly. If you are an SWL then this unit is fine but, if like me you like to monitor your transmitted audio whilst on air through headphones then this isn’t the unit for you. To prove the problem isn’t in the radio shack I put the BHI unit in the house some 30m away powered by 12v battery with nothing connected but a pair of headphones and still the unit suffered from RF interference even at QRP levels.

More soon …

Just one little rain drop is all it takes!

We’ve not had rain for over 6 weeks here in Eyke, Suffolk. The ground is incredibly dry and dusty. The farmers have been pulling vast quantities of water from their bore holes for weeks to keep the crops alive and we’ve been putting extra water out for the birds and animals that visit our garden daily.

Then one night we had about 30mins of light rain, not much at all and it was consumed by the dry earth is seconds. By morning you’d never of known it had rained however, strangely the next day when I fired up my QO-100 ground station I noticed that my signal into the satellite was way down from it’s normal S9+10dB level. Checking drive into the up-converter and SWR at the IC-705 everything looked fine. I then decided to check the SWR from the 2.4Ghz amplifier output only to find that it was off the scale.

I checked inside the enclosure for water ingress but, all was bone dry as normal. I disconnected the coax cable from the output of the amplifier and the IceCone Helix uplink antenna, tested with a multimeter and found everything was fine, no short and perfect continuity.

After scratching my head for a few minutes I decided to take both the N Type and SMA connectors apart to look for water ingress. Since the inside of the enclosure was dry I wasn’t expecting to find anything.

The N connector at the Helix antenna end on the dish LNB mount was perfectly dry, no water ingress at all. The layers of self amalgamating tape I’d put over the connector had done its job perfectly. Shame I had cut the tape off to remove the plug!

Upon removing the SMA connector at the amplifier end of the coax I noticed a tiny drop of water in the bottom of the housing where the pin goes through the white plastic insulator, not a good sign.

Sure enough upon further inspection I found that the white plastic disc that is situated above the pin on the centre conductor was wet and the coax braid felt damp. I knew immediately this wasn’t good.

At first I didn’t understand how there could possibly be water in the SMA connector when the rest of the enclosure was dry. Where the coax goes into the top of the enclosure there is a water tight junction that tightly grips the coax cable and seals it, supposedly stopping water ingress.

Since there was water in the SMA connector I feared that perhaps the water had gone further and entered into the amplifier so, I decided to remove the amp from the enclosure and remove the top cover to check.

2.4Ghz amplifier with top cover removed
2.4Ghz amplifier with top cover removed

After some close inspection I found the amp to be perfectly dry and free from water ingress, a relief for sure.

Before putting it all back together I decided solder on a pair of wires to the SWR and FWD-PWR pins on the amplifier and run them down into the radio room. This would then allow me to check the SWR and power output without having to get up to the enclosure with a multimeter.

Once this was done I then set about cutting 5cm of LMR-400-UF off at the SMA connector end so that I had a fully dry piece of coax cable to refit the SMA connector to. Having to do this outside and up a ladder wasn’t the easiest but, with a little perseverance and cooperation from the breeze I managed to get the pin soldered back onto the end of the coax and the connector back together.

I reconnected the amp to the 28v feed so that I could check the SWR and power output at full rating instead of the lower 12v setting that I had been using. Checking the voltage on the SWR pin I found that it fluctuated between 0.2v and 0.44v. This wasn’t what I was expecting as the PDF manual for the amplifier states that with a 1:1 SWR you should see 1.5v on the SWR pin.

DXPatrol 2.4Ghz Amplifier Manual Page for SWR/FWD-PWR voltages
DXPatrol 2.4Ghz Amplifier Manual Page for SWR/FWD-PWR voltages

After checking all the connections and retesting and getting the same voltage reading I emailed Antonio at DXPatrol detailing my findings and asking if he could advise on the voltages I was seeing. Sure enough in no time at all he came back to me saying that the manual was incorrect and that I should see between 0.2 and 0.5v on the SWR pin for a good SWR match. Being happy that the readings I was getting were fine I emailed back thanking him for his swift reply and then moved on to check the power output safely in the knowledge that the SWR reading was within tolerances.

Checking the FWD-PWR pin I found that on SSB the voltage was fluctuating between 2v and 3v, this equates to 6w and 9w output, about right for SSB. Switching to CW mode I found the full 4v was present on the FWD-PWR pin confirming I had the full 12w output from the amp. Of course this set off “Leila” on the satellite immediately as I was a huge signal on the bird with such high power output and was a reminder to reconnect the amp to the 12v supply instead to ensure I didn’t exceed 5w output and thus keeping to a considerate level on the transponder input.

After further investigation I came to the conclusion that the water ingress could only of come from the cable inlet on the top of the enclosure, it had then run down the coax cable into the SMA connector. Somewhat annoying as the inlet is supposed to be a water tight fixing. Once I had everything back in the enclosure and securely fitted, I covered the cable inlet and coax in self amalgamating tape in the hope that this would stop any further water ingress. I also re-taped the N connector at the antenna end as well to ensure it was also protected from water ingress in the future.

2.4Ghz ground station enclosure ready for testing
2.4Ghz ground station enclosure ready for testing

I’m hoping this will be the end of my water ingress issues and that I have a dry 2.4ghz future ahead of me.

More soon …

My First QO-100 Satellite QSO

I’ve been waiting for over a week so far for a male to male SMA connector to arrive from Amazon so that I can connect the 2.4Ghz up-converter to the 2.4Ghz amplifier. Since it still hasn’t arrived I decided to connect the up-converter directly to the IceCone Helix antenna to see if I could get a signal into the QO-100 satellite.

To my surprise I could easily hear my CW signal on QO-100 even though the total output from the up-converter is only 200mW.

I didn’t expect to be able to hear my signal since it’s a tiny amount of power that has to travel some 22500 miles to the satellite but, I could hear it and was amazed that it was peaking S8 on my SDR receiver.

2.4Ghz Up-COnverter connected directly to the antenna bypassing the 2.4Ghz Amplifier
2.4Ghz Up-Converter connected directly to the antenna bypassing the 2.4Ghz Amplifier

Being excited I put out a CQ call that was soon answered by OH5LK, Jussi in Finland. Jussi gave me a 579 report which I was extremely pleased with. He was of course much stronger at a 599+ at my end. We had a quick QSO and exchanged details without any problems at all. Its really nice to get a QRPp contact without any QSB or QRM.

M0AWS QO-100 1.1m off-set Dish and IceCone Helix antenna ground station
M0AWS QO-100 1.1m off-set Dish and IceCone Helix antenna ground station

Neil, G7UFO who I chat with regularly in the Matrix Amateur Radio Satellites room has posted a connector out to me so I’m hoping it will arrive on Monday and then I’ll be able to connect the amplifier and hopefully get a few SSB contacts.

UPDATE: I’ve since had 2 SSB contacts via QO-100 using just the 200mW O/P from the up-converter. Both times I got a 3/3 report not brilliant but, perfectly acceptable for the amount of power I’m putting out.

More soon …

UPDATE: QO-100 Node Red Dashboard

I’ve been making a few improvements to my QO-100 Node Red Dashboard whilst waiting for the 2.4Ghz hardware to arrive. I’ve added the ability to split the RX and TX VFOs so that I can tune away from the TX frequency for working split stations or for tuning to slightly off frequency stations. I also added a series of tuning buttons to the top of the GQRX side of the dashboard to enable easy tuning using the trackball connected to my Kubuntu PC. This worked well but, I really missed having a real VFO knob like a conventional radio.

As I had a Griffin Powewrmate USB VFO from a previous SDR radio I added it to the flow as well so that I had a physical VFO knob for the SDR receiver. Details on how I got it working using evtest and a simple BASH script are in the Griffin Powermate article.

M0AWS QO-100 Node Red Dashboard Flow
M0AWS QO-100 Node Red Dashboard Flow

The Node Red flow is looking a little busier with the addition of split mode and the Griffin Powermate USB VFO which has really enhanced the useability of the solution. It’s very impressive what can be achieved with Node Red with a little imagination. You really don’t need to be a heavy weight programmer to make things work.

M0AWS QO-100 Node Red Dashboard as of 07/06/23
M0AWS QO-100 Node Red Dashboard as of 07/06/23

I also put together some code to calculate the S Meter reading from the dBFS data the GQRX SDR software generates. It’s not 100% accurate but, it’s close enough to be useful.

On the IC-705 side of the Dashboard I also now display the 2.4Ghz uplink frequency so that it’s available for logging.

So with the QO-100 Dashboard ready to go live I have now started putting together the 2.4Ghz transmit path of the ground station. I have the 2.4Ghz transverter and matching 12w amplifier from DXPatrol, the IceCone Helix 2.4Ghz antenna from Nolle Engineering, some LMR-400-UF and connectors from Barenco and an appropriate water proof enclosure from Screwfix to fit all the kit into however, I’m now being held up by one simple little SMA male to SMA male connector that I need to connect the transverter and amp together.

The SMA connector has been ordered but, is taking a month of Sundays to arrive! Hopefully it’ll arrive soon and I’ll finally get on the QO-100 satellite and start enjoying the fun.

More soon …